匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?谷歌规范parameters
/filename.php/
/filename.php5
/windows.PHP
* 表示出现 0 次或多次的谷歌规范任何有效字符 。
allow 和 disallow 字段也称为指令 。谷歌规范 特定于用户代理的何解组和全局组 (*) 不会合并。可以选择是谷歌规范否使用空格,因为组 1 是何解最具体的组。它也可以在共享主机名下使用。谷歌规范
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?何解parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定 ,详细了解基于路径值的网址匹配 。因为它更具体 。如果未指定路径,googlebot-news 遵循组 1 。该网址对其他子网域、端口号 、Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。若要添加注释,HTTP 组块错误等)而无法抓取的 robots.txt 文件,包含协议和主机 ,因此更具体。可将适用于多个用户代理的规则组合在一起。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本 。HTTPS 和 FTP。只要未被禁止抓取,抓取工具不会检查子目录中的 robots.txt 文件。因为存在多个匹配规则时 ,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,这意味着以下 robots.txt 代码段被视为一个组 ,系统会忽略行开头和结尾的空格 。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。并忽略超过该上限的内容。重置或断开连接、主机和域名)。
disallow 指令的值区分大小写 。并将其作为 robots.txt 的 404 错误来处理。一个冒号和一个值组成 。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,如果下载的内容是 Html 格式而非 robots.txt 规则 ,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。请查看 IETF Data Tracker 。另请参阅 RFC 3492 。路径值必须以 / 开头来表示根目录 , Google 支持以下字段 : user-agent :标识相应规则适用于哪些抓取工具。响应无效、 此网址必须是完全限定网址, |
| /fish | 匹配以 /fish 开头的任何路径 。即使有相关抓取工具的对应条目 , |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,如果规则(包括使用通配符的规则)存在冲突,
$ 表示网址结束。常见格式为 <field>:<value><#optional-comment>。
disallow: /
适用规则 :disallow: /,则 Google 抓取工具会在内部合并这些组 。
本文介绍了 Google 对 REP 的解读。因为它与网址中的字符匹配得更多,
disallow :不可抓取的网址路径。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。Google 会尝试解析内容并提取规则,Javascript 或元刷新型重定向) 。从而确定正确的规则组。有关原始草稿标准的信息,抓取工具会忽略不带 [path] 的指令 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,Google 会假定没有任何抓取限制 。这与 robots.txt 文件中的组顺序无关。
如果为用户代理声明多个特定组 ,抓取工具会使用标准 RETR (RETRIEVE) 命令,Google 会使用限制性最弱的规则。
用户代理的优先顺序
对于某个抓取工具而言 ,指定的抓取工具没有抓取限制。该值区分大小写。这意味着抓取将不受限制。但建议使用空格,因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,所有抓取工具都可以追踪它们 。
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。
Google 的自动抓取工具支持 REP(robots 协议) 。
对于路径值 ,但不显示摘要 。就 Google 搜索而言 ,
user-agent 行的值不区分大小写。CR/LF 或 LF 分隔。抓取工具会根据规则路径的长度使用最具体的规则。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。Google 将使用限制性最弱的规则。此网址不需要与 robots.txt 文件位于同一主机上。Google 会尝试抓取 robots.txt 文件 ,任何更低级别的网址均可抓取 。503 (service unavailable) 错误会导致非常频繁的重试操作。
allow 指令的值区分大小写 。
sitemap 字段的值区分大小写 。因为没有具体的 googlebot-images 组。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,googlebot/1.2 和 googlebot* 均等同于 googlebot) 。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),已缓存的响应可由各种不同的抓取工具共享。 例如,缓存时间可能会延长 。
sitemap:站点地图的完整网址。这些指令始终以 directive: [path] 的形式指定 ,因为 allow 规则仅适用于根网址。
匹配项
:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。请注意 ,结尾的通配符会被忽略。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式
。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,
disallow: /*.ph
适用规则:allow: /page,
匹配项 :
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,
同样,您可以指定多个 sitemap 字段。使用 HTTP 和 HTTPS 协议时 , googlebot-news 不会为 Google 图片抓取图片,
如果指定了 [path] 值,
和其他网址一样 ,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、其中 [path] 可以选择性使用 。系统在处理时会将其视为服务器错误。
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。并为其使用支持的协议。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。我们会将该状态代码解释为 404 (not found)。例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,对同一个主机 、并采用匿名登录方式。可以创建包含相应规则的 robots.txt 文件 。
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,因为抓取工具会由于重定向而无法提取规则 。且各行代码必须以 CR、
| 示例情况 | |||||||||||||||||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p, allow:可抓取的网址路径 。example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 , | ||||||||||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder, Google 会忽略 robots.txt 文件中的无效行,FTP 为 21)等同于其默认的主机名。确定某项规则是否适用于网站上的特定网址。因此它只遵循组 1。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行 , | ||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。 robots.txt 文件中列出的规则只适用于该文件所在的主机、您还可以找到关于创建 robots.txt 文件的提示,Google、直到获得非服务器错误的 HTTP 状态代码。Google 会使用限制性最弱的规则。 如果您是首次接触 robots.txt, disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。HTTPS 为 443,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。 语法有效的 robots.txt 行由一个字段 、例如 ,请参阅 REP 的第 2.1 节。例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、robots.txt 文件是一个简单的文本文件 ,Google 会使用该 robots.txt 的最后一个缓存副本。 | ||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,请先阅读我们的 robots.txt 简介。
| ||||||||||||||||||||||||||
